HomePhabricator

crypto: Fix compilation for OpenSSL without deprecated APIs

Authored by Rosen Penev <rosenp@gmail.com> on Nov 8 2018, 3:07 AM.

Description

crypto: Fix compilation for OpenSSL without deprecated APIs

Added missing bn.h include.

Made engine.h include conditional, otherwise it would fail.

DSA_generate_parameters was deprecated long before 1.1.0.

Signed-off-by: Rosen Penev <rosenp@gmail.com>

Details

Committed
asnNov 8 2018, 9:32 AM
Parents
rLIBSSHaa899f8ec06e: cmake: Refresh the CMake Config files
Branches
Unknown
Tags
Unknown