HomePhabricator

pki_crypto: Use the new OpenSSL API to read PEM files

Authored by Jakuje on May 23 2019, 11:34 AM.

Description

pki_crypto: Use the new OpenSSL API to read PEM files

This allows the use of the new PKCS#8 PEM files and does not
limit libssh to using only the "traditional" PEM files, that
are not default in OpenSSL since 1.0.0 and which do not work
at all in FIPS mode.

Signed-off-by: Jakub Jelen <jjelen@redhat.com>
Reviewed-by: Andreas Schneider <asn@cryptomilk.org>

Details

Committed
asnWed, Jun 12, 10:41 AM
Parents
rLIBSSH0ce1e84d9046: pki_crypto: Use the new OpenSSL API to write new PKCS#8 PEM files
Branches
Unknown
Tags
Unknown