Page MenuHomePhabricator

sftp connect don't read ~/.ssh/config correctly
Closed, ResolvedPublic

Description

Hi,
I've got this config:

Host server
Hostname x.y.z.101
Port 22
User user
IdentityFile ~/.ssh/ecdsa

Host *
Port 4322
Compression yes
User user
ServerAliveInterval 15
IdentityFile ~/.ssh/rsa
HashKnownHosts no

Command "ssh server" works well, connects to ip and correct port = 22.
Krusader's new net connection to sftp "server" picks ip, but not port and after while returns timeout. By tcpdump, it tries to "default" port 4322. This was tried with libssh 0.6.3.

Tried in fresh install of Ubuntu 17.10, Krusader 2.6.0, kio-extras 17.04.3, libssh 0.7.5, but it doesn't read config at all.

Event Timeline

asn added a subscriber: asn.Aug 3 2018, 7:11 PM

This should be fixed already in master which will be released as 0.8.0 in the next days.

asn claimed this task.Aug 27 2018, 12:54 PM

Does this work with libssh-0.8.1 now?

asn closed this task as Resolved.Nov 6 2018, 2:15 PM

Fixed in libssh 0.8.1 or newer.