Page MenuHomePhabricator

pkg-config file libssh.pc should list zlib and gcrypt dependencies
Closed, WontfixPublic

Description

Currently, the pkg-config file is not sufficient to resolve dependencies when compiling applications that link to static versions of libssh.
Zlib and gcrypt should be listed in a "Requires:" line in libssh.pc if support for them is compiled into libssh.

Event Timeline

jamrial created this task.Oct 17 2017, 4:06 PM
asn closed this task as Wontfix.Nov 16 2017, 12:06 PM
asn claimed this task.
asn added a subscriber: asn.

I'm sorry but static linking is not encouraged.