Page MenuHomePhabricator

libssh 0.9.3 "DLLMain: ssh_init failed!" on Windows 10 (vcpkg)
Closed, ResolvedPublic

Description

  • Install libssh 0.9.3 (latest stable) using vcpkg on Windows 10:
vcpkg.exe install libssh
  • Link library to Qt C project
  • Or just create new VS 2019 C project and include <libssh/libssh.h>
  • Compilation have success
  • But executing failed on QtCreator
  • And Visual Studio 2019 too

On Linux platform it is work as native libssh-dev from repository as vcpkg distribution.

Event Timeline

Hello!

This is probably caused by the lack of threading support in the crypto library.

Which crypto library are you using? Do you know the flags used when compiling the crypto library?

I just use default package which coming from vcpkg. By default it's coming with mbedtls => so it's mbedcrypto.lib.
I don't use any flags cause I think that default package should work.

This is caused by a idiot programmer and I swear it must have happened in 48 hour window because THIS SHIT did not happen. I went to vcpkg to not have to explain open source stupid shit to other engineers that don't need to know about cmake pearl and other stupid shit.

Fix it now. Here is exactly why its failing.

This is not libssh's fault. Yesterday vcpkg master changed and new master branch is broken. Only reason I know this because I was setting up vcpkg with another programmer and called it a day. Next morning I get a it no work and all our automated builds broke.

Use this release:
https://github.com/microsoft/vcpkg/releases/tag/2020.01

I just did that now. I literally vcpkg libssh side by side git clone master vs the release. Old built with OpenSSL; new built with broken ass garbage mbtldls and crypto and some other trash.

Here is a screen shot of the difference:

Okay. Feel free to ban my account it was a dead drop :)

fedorskvorcov added a comment.EditedFeb 12 2020, 7:23 AM

Hello! Thank you a lot! You are absolutely right, idiotsandopensource and ansasaki! The problem is with mbedtls.lib. So need to wait when it will be fixed ^3^

fedorskvorcov closed this task as Resolved.Feb 12 2020, 7:25 AM